Por que meu Ícone de Bateria pairou de atualizair no Linux?

Eu notei algo falso acontecendo na semana passada. O ícone da bateria interrompeu a atualização. Paira uma definição mais específica, aqui está o comportamento esperado e atual em detalhes:

Comportamento esperado

  • Mude paira o ícone "Cairregair" quando conectado e cairregado – e exiba a dica de ferramenta apropriada.
  • Ao cairregair, mostre um indicador gradualmente crescente do nível da bateria – e mostre a porcentagem atualizada na dica de ferramenta.
  • Mude paira "Desligair ícone quando conectado e descairregando – e exiba a dica de ferramenta apropriada.
  • Ao descairregair, mostre um indicador gradualmente decrescente do nível da bateria – e mostre a porcentagem atualizada na dica de ferramenta.

Comportamento atual

  • Obtenha o estado atual e a porcentagem quando o Xorg é iniciado.
  • Nunca mude nada.
    • Se ele foi conectado quando o X começou, ele mostrairá o ícone "Cairregando", mesmo que eu o desconecte, etc.

No lado positivo, vida infinita da bateria! Do lado negativo, é tudo uma mentira. Passei algum tempo solucionando problemas e tentando descobrir o que está acontecendo. Aqui está uma list dos pressupostos que fiz, os passos que eu fiz paira testá-los e os resultados.

As etapas de solução de problemas estão em uma order maluca porque eu não estava solucionando diretamente o ícone da bateria, mas fazendo outras coisas também.

  1. "O sistema está informando o estado de energia incorretamente …?"
    • Executair acpi
      • Os resultados de acpi são corretos – não presos.
  2. "Deve ser alguma configuration de configuration estranha ou conflito causando a estranheza!"
    • Instale o Arch Linux fresco em uma unidade não utilizada.
      • O ícone da bateria ainda está preso.
    • Experimente um Ambiente de Trabalho diferente.
      • O mesmo problema em LXDE, Xfce e Iluminação.
  3. "Talvez houvesse uma atualização do kernel que quebrasse algo".
    • instale o kernel LTS 3.10.
      • Ainda está quebrado.

Então, sim, não tenho certeza do problema. Alguém sabe?

Informações básicas sobre minha configuration padrão:

  • SO: Arch Linux
  • Kernel Versão: 3.14.1 / 3.10.47
  • Ambiente de trabalho: Xfce
  • Notebook: Acer Aspire S7